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Introduction 

 Characterization of the subsurface is of fundamental importance to both 

geophysics and geology. Magnetic geophysics is one popular method in providing 

indirect information of the subsurface geology with both 3D and 2D being common 

for both academic and exploration studies. To help with the interpretation of 

magnetic anomaly maps and profiles we have developed a MATLAB based .exe 

software package (MagMod). This software is designed to allow a user to model 

arbitrary shaped 2D magnetic objects and compared to profiles obtained in a 

magnetic survey. The user can vary the number the number of objects as well as the 

shape to help match the observed profile.  

 In order to properly interpret magnetic anomalies within a magnetic survey 

a clear understanding of potential size and shape of their source(s) is required. 

While simple geometric shapes have relatively simple equations associated with 

them, modeling arbitrarily shaped magnetic sources efficiently requires extensive 

computation. Additional complications arise when numerous magnetic objects exist 

within a magnetic profile, each with its own unique magnetization. To deal with the 

complications of real world data we have developed a new software tool that is 

based on re-derived formulas from Talwani (1965). The formulas from Talwani 

(1965), slightly modified, have been implemented into an easy to use software 

package that is able to properly calculate the magnetic anomaly associated with any 

number or arbitrarily shaped objects. Within this software package the user can 

define each magnetic object by its induced magnetization, remnant magnetization, 

and magnetic susceptibility.  

Intended Use and Limitations: 
 

MagMod is intended to be used by academics, professionals, and students at 

a post-secondary level with some background in geology, geophysics, or related 

fields. As such, this document assumes a basic understanding of mathematics and 
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geophysics. The successful use of the program requires the user to input reasonable 

geological structures.  

 

 The software package was primarily developed to address the following 

questions: 

 

1) What is the magnetic profile created by an object of a certain shape or size? 

 

 This is accomplished by allowing a user to creating a arbitrary shaped 

polygon through a point and click process or by creating an ellipse a through a click 

and drag mechanic. MagMod V1.00 with produce the predicted anomaly based on 

the users imputed magnetic parameters. This can be useful for getting a broad 

understanding of what sort of profiles different shapes create.  

 

2) How many objects are required to produce a desired magnetic anomaly profile? 

 A user can import either a 2D magnetic profile or a magnetic anomaly map 

and then create a 2D transect from the imported map. The loaded profile can then 

be compared to the user created profile. Adjustments are then made manually in 

order to match the observed (imported) and predicted magnetic profile.  

  

3) How does remnant magnetization change a magnetic profile? 

 

 Remnant magnetization is an often overlooked aspect of modeling magnetic 

profiles even though remnant magnetization is present in almost all rock and 

sediments. MagMod V1.00 allows the user to input the strength and direction of the 

net remnant magnetization for each object. The net magnetic anomaly is produced 

through the superposition between induced and remnant magnetization.  
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MagMod V1.00 is designed to replicate the magnetic anomalies associated with only 

2D objects and therefore will have reduced effectiveness when complex 3D objects 

exist in the subsurface. However, for simple and relatively symmetric objects (e.g. 

dikes, kimberlites, spherical ore bodies) the 2D approach should be sufficient.   

Installation: 
 

1 ) To install MagMod V1.00 open the "MyAppInstaller_mcr.exe file 

. 

 

 

2) This will open up the following screen. Click "Next >" 
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3) Choose the installation folder and click "Next >" 
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4) To proceed you will need to install MATLAB Runtime if it isn't already installed. If 

it is not installed the following screen will appear. Click "Next >" through the next 

few screens to install MATLAB Runtime and MagMod. 
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5) To Open MagModV1.00 go into the installation folder and into the application 
subfolder and open the file called MagMod. This should load the graphical user 
interface used in MagMod. See the tutorial section on how to use MagMod 
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Using MagMod V1.00 

 This section is intended to be a overview and tutorial of the features present 

in MagMod V1.00. This a step-by-step guide of how to create and compare magnetic 

profiles as well as how to save and export any outputs created.   

 

First open up MagModV1.00 and the graphical user interface (GUI) should load. 

 

 

 

MagMod V1.00 is divided into separate tabs into two section. The left side contains 

the Introduction, Background, Map Properties, Options, and Import tabs. While the 

right side contains plots associated with magnetic profiles and the subsurface.   

 

Undocking and Resizing: 
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 The left side tabs and the right side plots can be undocked from each other by 

clicking the arrow in the top right side of the GUI. The relative sizing between the 

tabs and plots can also be adjusted by dragging the divide between them. 
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Saving Data: 

 To save a current project simple click on the "Save" button at the bottom of 

the GUI or go to File → Save  
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Loading Data 

 To save a current project simple click on the "Load" button at the bottom of 

the GUI or go to File → Open. Click on the .mat file that corresponds to the save file 

you would like to load. 
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Exporting Data 

 
 
 You can export much of the data you create or load into MagMod V1.00 into 

an Excel file *.xls file by clicking the "Export" button for by going File → Export. 

 

The following data (when applicable) is exported into separate sheets within the .xls 

file.  

 

Sheet Name: "Background data" 

- Contains all data inputted into the "Background" tab. 

 

Sheet Name: "Map data" 

- Contains all data inputted into the "Map" tab. 

 

Sheet Name: "Object data" 
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- Contain all data inputted into the "Objects" tab. 

 

Sheet Name: "X object's position data" 

- Contains the positional data for the user created subsurface object X (created in 

the "Objects" tab and plotted in the Subsurface Plot). Each object is given its own 

sheet. 

- If the object is a polygon the exported is the vertices of the polygon. 

- If the object is a ellipse the exported is the 100 data points used to define the 

ellipsoidal shape. 

 

Sheet Name: "Map Profile Location"  

 

- If a map profile was imported and a magnetic anomaly profile was created from 

the map (See tutorial) the start and end x-y coordinates (in m's) of the profile are 

exported into this sheet. 

 

Sheet Name: "Map Profile Data" 

 

- This is the magnetic profile data (in nT) created by the user defined objects. 

 

Sheet Name: "Imported Profile Data" 

 

- This is the magnetic profile data (in nT) imported into MagMod. 

 

Sheet Name: "Map Data Grid Bounds" 

 

- If a user imported a magnetic anomaly map these are the bounds inputted by the 

user for this map. 
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Sheet Name: "Map Data Grid (nT)" 

 

- If a user imported a magnetic anomaly map this is the anomaly data associated 

with the map in grid format. 

 

Saving and Modifying Figures 

 

All plots and imported figures can be modified and then saved into a variety of 

formats (e.g. .pdf, .png. tiff. jpg, ect...) by clicking on the corresponding "View" 

button. This opens up the figure into a separate window where a variety of options 

can be modified (e.g. grid lines, colour bars, line width, ect...). The figure can then be 

save by going to File → Save As. 

 

 

 

Help with Function 
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 The user can open up the User Manual by going to Help → Export. However, 

for quick help many functions and tabs have a "Help" or "?" button. By clicking these 

buttons a side window with a short explanation of the function or variable in 

question will pop up. Click the button again to close the window. 
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19 

Tab Layout 
 

Introduction Tab: 

 

 

 

 

The "Introduction" tab contains basic information on how to get started. To move to 

the Background tab either click the tab or  click the "Next" button. 

 

 

 

 

 

Background Tab: 
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The "Background" tab contains all the inputs required to describe the location of the 

survey. This includes the site latitude, site longitude, induced magnetization, 

inclination, and declination.  

 

The site latitude/longitude should be the value at the center of the profile. The 

induced magnetization should be the value of the Earth's magnetic field at the site 

location. The inclincation and declination are the values for the site location. 

 

 

 

 

Map Properties Tab: 
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The "Map Properties" table sets the domain for the profile used in MagMod. Any 

imported profile will automatically update the "Minimum X-Value", "Maximum X-

Value". Map profiles will also adjust the "X-Offset from North" value to the 

orientation of the loaded profile 

 

Minimum X-Value: Defines the left boundary for any calculated profile and adjusts 

both the profile and subsurface plot accordingly.  

 

Maximum X-Value: Defines the right boundary for any calculated profile and adjusts 

both the profile and subsurface plot accordingly.  
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Maximum Depth: Defines the maximum depth shown in the subsurface plot. This 

should be of sufficient depth to fit any user created objects. 

 

Minimum Depth: Defines the minimum depth shown in the subsurface plot. This 

should be of sufficient depth to fit any user created objects. 

 

X-Offset from North: This value defines the orientation of the magnetic anomaly 

profile. For example a S-N orientation should have a offset of 0o while a W-E profile 

will have a offset of 90o. 
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Objects Tab: 

 

 

 

In the "Objects" tab the user is required to create the magnetic objects responsible 

for a magnetic anomaly. The user does this by inputing the proper remnant 

magnetization data for their object(s) into the data table. The name for each 

individual object must be unique.  

 

The user can add additional objects by clicking the "Add Object" button. The user 

can delete objects by highlighting a cell in the column of the object that they wish to 

delete and then click the "Delete Object" button. 
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Once the user is happy with the data table they click "Accept Object" which will 

populate the popup menu in the "Draw Your Object" panel. For each object the use 

must either create a polygon or ellipse. 

 

Upon clicking "Create Polygon" or "Create Ellipse" the user will pick a colour for the 

object (e.g. orange for the rectangle in the above figure). For a polygon the user 

clicks in the subsurface plot (bottom plot) at the location of each vertex in a 

clockwise fashion. To close the polygon either double click or click the starting 

vertex a second time. For an ellipse the user will drag the ellipse into the shape and 

size desired. The created ellipse is defined by 100 data points.  

 

The "Unlock Shape" button allows the user to manipulate their shape after it has 

been created (e.g. the circle in the previous figure).  

 

The "Lock Shape" button freezes the shape in place (e.g. the orange rectangle in the 

previous figure. 

 

Clicking "Calculate" will produce the predicted anomaly from the shapes inputted by 

the user. Before clicking "Calculate" ensure that you have fill out the data table 

correctly and have drawn the correct shape for each object! 
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Import Tab: 

 

 

 

The "Import" tab allows the user to either load a 2D magnetic profile ("Load Profile 

Data")  into the profile plot or to load a magnetic anomaly map ("Load Map Profile") 

from which a profile can be created. These profiles must be in a .xls or .xyz format 

using UTM coordinates (use example spreadsheets as a template or see the figures 

below) to be loaded properly. 

 

Loading 2D Profiles: 
 

If the user loads a 2D profiles by clicking the "Load Profile Data". The profile is 

plotted into the profile plot (top plot). See the following figure for the proper .xls 

template and the output created. 



26 

 

 

 

 

 

Loading Map Profiles: 
 

If the user has a magnetic anomaly profile map available they can load it into 

MagMod V1.00. The proper template is as follows (see example map profiles as 

well). The spreadsheet should contain magnetic anomaly values in nano-tesla to 

work properly, with each cell corresponding to a data point in x-y space.   
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If the user loads a map profile by clicking the "Load Map Profile" they are asked 

what the dimensions of the plot are in meters. The X-boundaries correspond to the 

east-west domain and the Y-boundaries correspond to the north-south domain. This 

will then set the x-y position for each data point in the loaded from the spreadsheet.  
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The profile is then loaded into the left-hand panel.  
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The user clicks and drags across the map profile to get a magnetic anomaly plotted 

into the profile plot (top plot). If you want S-N profile, the first point on the profile 

should be the most southern point. Then move the line towards the North. The X-

Offset from North will be 0o. If you move your profile from the north to the south 

(The X-Offset from North will be 180o), then ‘drag’ the line from the north to the 

south. 

The "Map Properties" are automatically updated when the profile is created.  
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Tutorial 
 

Consider that you have a dataset that contains magnetic anomaly data and you want 

to determine the shape and location of subsurface objects that are producing the 

anomaly. The following is a simple tutorial that a user can follow to properly use 

MagMod V1.00. 

 

Step 1: Load MagMod V1.00  

Load MagMod V.100 by double clicking the icon and it should open the interface. 
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Step 2: Import a profile you wish to model. 

Go to the Import Tab and click either “Load Profile Data” or “Load Map Profile”. In 

this tutorial we will open a map profile. Once clicked a dialog box will load asking 

you to input the boundaries for your map. 

 

 

For this tutorial we will input the “X Lower Boundary” and the “Y Lower Boundary” 

to be 0m. The “X Upper Boundary” and the “Y Upper Boundary” is inputted as 

1000m. Click “Ok” and choose the appropriate file to load, in this case 

MapExample3.xls.  
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This should load the map into the left side panel. 
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The user then drags a line across the profile. In MapExample3.xls we see that there 

are 2 symmetric objects in the E-W direction, therefore the most useful profile may 

be an S-N profile as shown below. 
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Step 3: Update the Background Tab 

The background tab should be updated with the location of the site, and the strength 

and direction of the local magnetic field. For this example we will keep the default 

values. 
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Step 4: Update the Map Properties Tab 

Update the map properties to correspond to the domain you wish to model. By 

default the “Minimum X-Value”, “Maximum X-Value”, and the “X-Offset from North” 

are matched to the loaded map profile. For this example we will keep the default 

values. 
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Step 5:  Create Object Properties 

For this profile we see that there appears to be two distinct objects. Therefore in the 

Objects Tab we create will two objects. This is done by clicking the “Add Object” 

button once which will create two entries into the data table. The data table is then 

filled each for each individual object (e.g. Object1 and Object2). For this example we 

will assume both objects have the same magnetic profiles. 
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Click Accept will update the “Draw Your Object” panel and allow objects to be drawn 
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Step 6: Draw the Object(s) 

In the popup menu choose the object you wish to draw (e.g. Object1) and then click 

either “Create Polygon” or “Create Ellipse”. In this example “Create Polygon” was 

chosen, which brings up a colour menu which allows the user to choose the colour 

of the object. 

 

 

Once the colour has been select the mouse cursor is brought to the bottom right 

plotting area where a crosshair should be visible. 

 

 



40 

 

 

The user then click to create a vertex for the polygon. Additional vertices need to 

be place in a clockwise fashion. 
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To close the polygon the last vertex can either overlap with the first vertex or the 

user can double click. 

 

 

 

After the first object is finished other objects can then be created in a similar 

fashion. 
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Step 7: Calculate Profile 

Once the objects have been created the magnetic anomaly profile that they create is 

produced by clicking “Calculate”.  
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Step 8: Modifying Objects 

If the two profiles do not match the objects can be tweaked in shape/depth by 

unlocking (“Unlock Shape?” button) the current shape (if it isn’t already unlocked). 

The user can reposition each individual vertex by clicking the vertex and dragging to 
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a new point. The user can also drag the shape to a new location. Alternatively the 

user can modify the data table. If the user modifies the data table they must click 

“Accept Objects” again. 

 

 

 

 

 



45 

Step 9: Interpretation 

 

In the example we have two rectangular objects that create a profile similar to the 

observed map profile. Since the objects are symmetric in the E-W direction we may 

suggest the following interpretation in cross section and map view. However, it is 

important to realize that these are non-unique solutions! 
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