
Preparing graphs for presentations, websites, and publications 
 
In this lab, we will cover various options to save and subsequently manipulate graphs for PPT slides, for your project 
websites or publications/thesis documents. We will cover: 
 

• Different types of graphics and file formats 
• Saving R graphics for documents and/or digital media 
• Reducing image file sizes 
• Editing graphics in PowerPoint and Adobe Illustrator 

 
Type of computer graphics 
 
There are two main types of computer graphics/images: 

1) Raster graphics: these images are based on pixels, which are basically colored dots on your monitor. The image 
itself is simply a seamless grid of these pixels. Pixels can carry information beyond just color, as with satellite 
images and such.  

2) Vector graphics: these images are made from individual graphic components, such as lines, curves, polygons, etc. 
Each element in a vector graphic is defined by coordinates or expressions/formulae that define its shape. Areas of 
a vector graphic that are not occupied are actually “empty” rather than just filled with a background color (as in 
rasters).  

 
Generally speaking, raster graphics are useful for images and photos whereas vector graphics are more useful for figures, 
diagrams, and text. 
 
Rasters have the advantage of being easy to create, easy to view, can handle large amounts of very complicated imagery in 
relatively small file sizes, and consistent in their look. However, they are at a set resolution, so may become useless at large 
scales. Vectors have the advantage of maintaining their quality at any scale and being relatively small file sizes for simple 
images. However, software for viewing and editing them is more complicated and not as readily available. Typically, vector 
graphics can be easily converted into raster images, but converting rasters to vectors is almost always impossible/messy. 
 
Typical vector formats include PDF (Adobe Acrobat), EPS (Encapsulated Post-Script), EMF or WMF (Enhanced or Windows 
MetaFile), SVG (Scalable Vector Graphic), or AI (Adobe Illustrator). Typically, these files are compatible between various 
vector-file editing software packages (Illustrator, PowerPoint, etc.). 
 
You should be familiar with many typical raster formats, which include JPG, PNG, TIFF, BMP, GIF, etc. Most raster graphics 
software (e.g. Photoshop, MS Paint, etc.) will open any type of raster image. The key to raster formats is that some are 
“lossless” , meaning they preserve all the information in the image file, and some are “lossy”, meaning they lose some 
information in the file as a trade-off for smaller file sizes. Sometimes, images can be compressed without a major loss of 
quality while other images seem to degrade in quality right away. MP3 is an audio version of a lossy format, as the audio is 
compressed, resulting in a slight loss of quality (but with a considerable file size savings). 
 
JPG and PNG are typical lossy image formats, while TIFF is a typical lossless format. Most lossy formats can be saved with a 
variety of compression settings, resulting in different balances of quality vs. file size. Generally speaking, PNG files are 
preferable to JPG files, as they tend to maintain a better quality to size ratio when working with plots and other R graphics.  
 



PART I – Saving for print documents (e.g. publications, your thesis, etc.) 
 
If you would like to save an R graphic for a print document such as a paper or thesis, you might think that you would just 
save the image in R as a PNG or JPG. However, this isn’t always the best idea, as you don’t have control over the 
compression, etc. of the file in R. Instead, I would suggest that you save your graphics as PDF (vector) documents and then 
use a program such as Adobe Acrobat or Adobe Photoshop to save them as raster images. 
 
To do this, save your R graphic as a PDF. You can do this in R simply by 1) selecting the graphics window so that it is active, 
2) from the drop-down menus, select File -> Save As -> PDF. A dialogue box will open where you can save the file. 
 
You can also do this in your script with a line of code (you must have a plot window open): 
 
 savePlot(“c:/My File Path/Filename.pdf”, type=”pdf”) 
 
This savePlot() command will work with other file formats also (PNG, EMF, JPG, etc.). Have a look at the help file at 
?savePlot for more info.  
 
There are some issues with the savePlot() command when using R for Mac OS. If you have trouble on your Mac, try using 
x11() or quartz() to generate plot windows. You may also want to read about the device() command. If you are using R for 
the Mac, let me know and I can show you a few tricks. 
 
Saving your PDF to an image in Acrobat 
Once you have your PDF, open it with Adobe Acrobat, then choose File -> Save As and select the image type that you would 
like to use. Notice that for many image formats (JPG, PNG, etc.), there is a ‘Settings’ button on the right. You can click that 
to change the compression settings of the file. 
 
Saving your PDF to an image in Photoshop 
Photoshop works almost exactly the same as Acrobat for converting PDFs to raster formats, except that you have much 
more control over color schemes, etc. To simply generate a raster, you can open the PDF in Photoshop and ‘Save As’ an 
image format, just as in Acrobat. 
 
You can easily save images with different color and compression settings (in the ‘Saving for the Web’ section). This can be 
useful for print images also, as you may want to keep your document file sizes down a bit (no journal wants a 50MB PDF 
submission!). 
 
You can try this with any PDF or image file that you have created:  
 
1) Open the image (PNG, GIF, PDF, etc.) in Photoshop. 

2) File -> Save for web and devices (Alt + Shift + Ctl + S) 
This opens a dialogue box that looks really complicated and very intimidating. Relax.  

3) Change the tab (top-left) to 2-up. This shows your original image next to the image that you will be saving. You can use 
this to see the quality of the output image with the current settings (on the right). You can select either image to see 
the settings on the right. For now, select the image that does NOT show “Original” at the top-right. 



4) Select the file type that you would like to save to (GIF, JPEG, PNG-8, PNG-24, WBMP). 
Each file type supports different settings and will result in slightly different images and file sizes. You may have to play 
around with this a bit to find out what works for you. 

5) For now, select PNG-8 from the list. 

6) Change the color mode to “Selective” and change the dithering to “No Dither”. (Again, you can play with these until 
you find what works for your image.) 

7) Change the number of colors, starting from 256 and decreasing until you see a change in the quality of your output 
image. It shouldn’t be noticeable for a few changes, then it should become obvious when the colors are dropped to far. 
Go back to the last color setting that looked acceptable. 

8) Look at the bottom-left of each image. You should see some text stating whether the image is the “original” or the 
“PNG-8” version. You will also see a file size listed there. Notice how much smaller your new image is. You can play with 
the settings a bit more to see how the file sizes change. The colors that are preserved in the image are shown in the 
palette on the right. 

9) The other settings on the right are either fairly intuitive or completely confusing. Notably, you can control whether 
transparency is preserved in your image (not supported in PNG-8), and whether to dither the transparency (usually you 
would select “No Dither” here also). 

10) The last setting you might want to change is the “Image Size” under the palette. This simply changes the dimensions of 
the output image. For the web, you’ll want to save the image in a size as close as possible to the size you want to 
display. Photoshop will do a MUCH better job of resizing images here than a web browser will do, so save them at the 
size you want. For publication, you can over-estimate sizes a bit, but smaller images are also smaller files. 

11) Click the “Save” button and proceed as usual. 
 
 
 
PART II - Saving for digital documents (e.g. PowerPoint, websites, etc.) 
 
Saving graphics for digital use, such as on websites or in presentations, is very similar to saving for print documents. You will 
start by saving your graphic out of R just as in PART I above. You can do this either with the menus or with the savePlot() 
command. 
 
The file type you choose to save to should be a vector file type. Whether you choose a PDF or other format (EPS or WMF) 
depends on what you plan to do with this graphic.  
 
If you plan to use or modify the graphic in PowerPoint, save as a WMF or EMF (metafile) format. 
If you plan to modify the graphic in Adobe Illustrator, save as a PDF format. 
 
If you’re not sure, save it as a bunch of different formats! 
 
Now, we want to bring the graphic into a different program. Each program has their own quirks with importing files, but 
they’re generally easy to deal with provided you use the right type of graphics file. 
 
We will walk through the following procedures in class. 



 
Importing and manipulating graphics in Microsoft PowerPoint  
To import the graphic into Powerpoint, just drag it onto a slide. To edit the image, you will have to ungroup it, as it is 
currently all “grouped” into one object. Right-click the image and choose Group -> Ungroup. You may need to delete the 
outer frame to get access to the graph elements below. You can now edit the text and move, color, or delete any element. 
Once finished your edits, you may save the file as a PowerPoint presentation, or you may export the slide as a new raster or 
vector file. 
 
Importing and manipulating graphics in Adobe Illustrator  
This works essentially the same as PowerPoint, but with slightly different commands. You can simply open your PDF graphic 
directly in Illustrator. To ungroup the objects, you must select everything and, from the pull-down menus, select Object -> 
Clipping Mask -> Release. All your vector elements should now be separate objects. Once you make your desired changes, 
you can save the file as a PDF or an AI file. 
 
 
 
PART IV – Modifying a graphic in Microsoft PowerPoint 
 
If you want to use an R graphic in a presentation, you can make adjustments to it in PowerPoint. Once you have a graphic 
built in R (as close to a final version as possible), you easily clean it up a bit in PowerPoint. This exercise is not meant to be 
an introduction to PowerPoint. It assumes that you have some knowledge of how to use PowerPoint. If not, there are 
plenty of good tutorials on the internet. Google will help you find them. 
 
For this example, we’ll use an output graphic from an NMDS analysis. The R-code and data to produce the NMDS is 
provided on the course website. Save the output graphic as an EMF file. The EPS format will also work well for modifying in 
PowerPoint, but it treats point symbols and text slightly differently. I would suggest that you always save your graphics as 
both formats and have a look at each in PowerPoint before you decide which to use. 
 
After you build your NMDS, you’ll notice that there are some undesirable things going on that we’ll want to clean up (e.g. 
overlapping text, spacing inconsistencies with vector text, colors, etc.).  
 
1) Open PowerPoint and drag you graphics file (EMF) into a blank slide. 

2) You may notice under the ‘Format’ tab that your image came in at a size of 7” x 7”, just as we defined in R. If we open 
this file in other editing software, that sizing will be maintained. This can be very useful for building graphics in R that 
are appropriately sized for papers, publications, presentations, etc. 

3) Center the image on the slide using the ‘Align’ tools in the ‘Format’ tab or under the ‘Arrange’ button on the ‘Home’ 
tab. 

4) Select the image and Right-Click -> ‘Group’ -> ‘Ungroup’. 
You may be asked to convert the image to a “Microsoft Office drawing object”. Say ‘Yes’ to this.  

5) If all the elements in your image still appear to be grouped together, repeat the Right-Click -> ‘Group’ -> ‘Ungroup’ until 
all the elements are separated. You may see a slight change or position shift in some of the elements. This is no 
problem. Keep going. You can now select and modify each element (symbol, line, text, etc.) separately.  



6) First, let’s delete the transparent square background that has come in with your image. Click on some empty space just 
beside the title of the plot. You should select a clear box that surrounds the plot. Delete this. 

7) Now, let’s adjust all the point label text that is overlapping other elements so it looks clean. You can do this by selecting 
individual pieces of text and dragging them to move them around. I wouldn’t move every piece of text, just the 
crowded ones. 

8) We can also adjust the text labels of the grey vectors. If you need to, move those labels too.  

9) Make the vector label text a bit more visible. Select them all by holding the Shift key and clicking on each one. If you 
select something you don’t want, you can always just keep holding Shift and click it again to deselect. Once they are 
selected, change the text color to a darker grey and change the font to bold. The text attribute buttons are in the 
‘Home’ tab. NOTE: To change the attributes of the text, you can’t have an active cursor in the text box. You need to 
click on the text box border to select the text box without getting a cursor. 

10) We can now make the vector arrows more visible also. Select them all by holding ‘Shift’ and click on each of them. Note 
that you need to select BOTH the line and the arrowhead, as they are separate elements. It may be easier to select 
arrowheads by dragging a small box around them rather than clicking on them. With them all selected, we will change 
the line attributes (at the right of the ‘Home’ tab or under the ‘Format’ tab): 

a. Under the ‘Shape Outline’ button, select the same darker grey that you did for the vector labels. 
b. Also under the ‘Shape Outline’ button, click on ‘Weight’ and select a thicker weight (maybe 1½ pt). 

11) The axes and title are often grouped together as well, so you may have to select one of them and repeat the Right-Click 
-> ‘Group’ -> ‘Ungroup’ again. Notice, however, that this may also ungroup all the elements making up each symbol 
(each dot) on the plot. So, I would not ungroup the axes and titles until you’re done moving things inside the plot itself, 
to avoid editing the points by accident. 

12) Rotate each of the y-axis tick labels. Select them all and use ‘Arrange’ -> ‘Rotate’ -> ‘Rotate Right 90°’. You can also do 
this be selecting them one-by-one and using the green handle to rotate them (hold ‘Shift’ to force the rotation to lock 
at 45° intervals).  

13) Increase the size of the axes labels by selecting them and changing the font size (in the ‘Home’ tab) to 16 pt. Change 
the size of the title to 18 pt.  

14) We can also make a legend in PowerPoint for the symbol colors, to the right of the plot. To do this, we’ll copy some 
elements off the plot into the right margin and add some text. 

a. First, we’ll make the text. Insert a new text box in the right margin by clicking on the text box icon in the 
‘Drawing’ section of the ‘Home’ tab. Click in the right margin where you want your legend to start. 

i. Type in the names of each of the biomes we had in the data (Boreal, Grassland, Montane, Parkland).\ 
ii. When done typing, click on the margin of the text box to select the box (your cursor will disappear). 

Change the font size of the text box to 16 pt. 
b. Copy one point of each color into the margin beside the appropriate label in the legend. Remember that these 

points are now several ungrouped points, so you’ll need to select an entire point by dragging a box around it 
(a ‘selection window’). 

i. Select an entire point with a selection window.  
ii. Group this point together: Right-Click -> ‘Group’ -> ‘Group’. If you can’t click on it without deselecting 

it, you can use Ctrl+G instead. The point is now grouped as one element. 
iii. Make a duplicate of this selected point either with Ctrl+C (copy) and Ctrl+V (paste) then moving it to a 

new location, or alternatively by dragging the point to a new location while holding the Ctrl key.  



c. Once you have copied one point of each color into the right margin roughly beside the correct legend entry, 
you can select them all with a window and align the points (‘Arrange’ -> ‘Align’ -> ‘Align Center’) and evenly 
distribute them (‘Arrange’ -> ‘Align’ -> ‘Distribute Vertically’). 

15) You can now save your new graphic for use in presentations (keep it in PPT format) or in papers and publications (save 
it as an EMF file). 

a. Save ‘File’ -> ‘Save As’ -> ‘NMDS_new.emf’ 
When prompted, select ‘Save Current Slide Only’ to keep only the one graphic in the file. 
NOTE: Your graphic will now be the size of a PowerPoint slide (no longer 7” x 7”). But you can always ungroup 
it in another program and remove the background. 

b. I would also save your PowerPoint file as well. This can be handy if you want to quickly use the graphic in a 
presentation.  

16) Open a new MS Word document and drag this ‘NMDS_new.emf’ file into the page. It should look nearly identical to 
how it looked in PowerPoint, though it will be grouped as a single object again. 

 
 

PART V – Modifying a graphic in Adobe Illustrator 
 
A very good alternative to PowerPoint for graphics editing is Adobe Illustrator. It is much more powerful and (in my opinion) 
much easier to use. It also give your more control over the output appearance of your graphics. However, the files that you 
output with it may not be as perfectly compatible with other Microsoft products like Word or PowerPoint. However, you 
can make very clean looking PDFs or images that can be inserted into your papers, your thesis, or your website. 
 
This exercise assumes that you have never used Illustrator before, but that you have some basic computer literacy. I have 
included a key to the Illustrator tools on the next page. Note that when you use Illustrator on different computers, you may 
have different toolbars showing and they may be in different places. You just need to get used to this and figure out where 
to find other toolbars. 
 
To show toolbars that we may use in this exercise, if you can’t find them on your screen, you can enable them in the 
‘Window’ pull-down menu. (Hint: if there’s a checkmark beside a toolbar, its already on your screen…somewhere). The 
most critical toolbars will be: Tools, Color, Layers, Swatches, and Stroke. If these aren’t checked on, you’ll want to turn them 
on. The one other toolbar we’ll need is for text. All these controls are in the same box containing the Paragraph, Character, 
and OpenType tabs. If you don’t have this box available on your screen, you can enable it in ‘Window’ -> ‘Type’ -> 
‘Character’.  
 
For this example, we’ll use an output graphic from an MRT analysis. The output PDF from an MRT analysis is available on 
the course website (MRT_Out.pdf). 
 
1) Open Adobe Illustrator (dismiss any pop-up windows if they appear) and open the MRT_Out.pdf file (either through the 

‘File’ -> ‘Open’ menu or by dragging the PDF into a blank Illustrator window. 

2) You should notice that Illustrator has created an “artboard” (looks like a page or a slide) that matches the size of the 
original PDF. You can always zoom into the artboard by double-clicking the pan tool (the hand) in the toolbar. You can 
change the size of your artboard by clicking the artboard tool. This will show the dimensions of the current artboard 
and allow you to change just about anything about it. Click any other tool to close the artboard view. 



3) Just as in PowerPoint, all our graphic elements are grouped together and we want to edit them independently. While 
Illustrator has a ‘Group’ function, this isn’t what we want in this case. Start by selecting everything in your graphic, 
either by drawing a window around the entire artboard (not just around the graphics) or by using Ctrl+A to select all. 

4) ‘Object’ -> ‘Clipping Mask’ -> ‘Release’ 
All your graphic elements should now be individual objects. 

5) Delete the transparent background. Do this by dragging a window across the edge of the artboard without containing 
any graphic elements. Push Delete. 

6) First, let’s get the legend out of the way. Use a selection window that overlaps all the legend items to select them all. 
Drag them to the top-right of the graphic (inside the artboard, but not overlapping the tree). 

7) We’ll also put the legend into its own Layer. Illustrator lets you use layers to organize graphical elements. This is like 
having different parts of your graphic printed on a bunch of transparent pages, all laid over top of one another, where 
you can reorder these pages (layers) and move elements from one page (layer) to another. This is VERY handy, 
especially when you are working with very complicated graphics, like conference posters. 

a. In the ‘Layers’ window, click on the page-like button at the bottom left. This makes a new layer. 
b. Double-click this new layer in the list. This opens a dialogue box that lets you rename the layer (let’s call it 

“Legend”) and change the selection color of the layer (the color of the handles, etc. when you select elements 
in this layer). There are also other self-explanatory options here that you can toggle. Leave them for now and 
hit OK. 

c. With all your legend items selected, single-click the “Legend” layer in the Layers window to highlight it. 
d. Right-click anywhere in your drawing window and select ‘Arrange’ -> ‘Send to current layer’.  
e. Your legend items are now all in the “Legend” layer. In the Layer window, you can now chose to show/hide 

them (the eye icon) or lock/unlock them (the lock icon, just beside the eye). Hidden layers can’t be seen (duh) 
and won’t be printed and locked layers can’t be modified. Try it out. 

f. You can also click the arrow to the left of the layer name to display all the elements in that layer. Individual 
elements can be selected this way by clicking on each element in the list just to the right of the circle at the 
right. You can also select all elements in this layer by clicking to the right of the circle in the layer title bar. You 
can also hide or lock individual elements. 

8) Change the case of all the legend items to lowercase. You DO NOT need to re-type them all. Just select all the legend 
text with an overlapping window and from the drop-down menus chose ‘Type’ -> ‘Change Case’ -> ‘lowercase’. 
Awesome. 

9) Sometimes text can get a bit weird when you export/import it like we have here. If you look at the legend text, you 
may see characters that are closer together than others. This is common (don’t know why). You can fix this by selecting 
all the legend text and changing the horizontal character spacing in the ‘Character’ toolbox to zero. The icons in this 
box are fairly intuitive, but you may have to play with them a bit to see what they all do. 

10) At each node of the MRT, remove the numbers and the “n=” text by selecting it and pressing Delete. 
Hint: if you think you might need these later, remember that you can always move them to a new layer and hide it.  

11) Slide the error estimates up a bit, closer to the tree. Select them and move them upwards. You can move them in 
straight directions (or at 45° locked intervals) by dragging and holding the Shift key. If you wanted to copy the element, 
you could drag it and hold the Alt key. 

12) We have repeated colors in our legend. This is not good. We will replace them with new colors. An easy way to do this 
is by creating a swatch, which is a palette of discrete colors that we are using. These will be listed in the ‘Swatches’ tab 
(usually just below the ‘Colors’ toolbox). 



a. Select the first legend entry (the light blue box). In the ‘Color’ toolbox, you will see that the fill square is the 
same light blue while the stroke square is white with a red line through it (indicating no color). 

b. Drag the light blue box into the Swatches window. That color should remain saved there for you to select at 
any time. You can do the same with the next two shades of blue. 

c. To change the color of the fourth box (let’s use light green instead), start by selecting the box. The same light 
blue color as in (a) will show up in the ‘Color’ toolbox as the fill color. We can change this in a few ways. The 
options are: 

i. Double-click the light blue fill box in the ‘Color’ toolbox. This will bring up a color palette tool in which 
you can select another color. This is pretty straightforward. 

ii. Simply select a point in the rainbow color palette at the bottom of the ‘Color’ toolbox. You can adjust 
this color by moving the RGB color sliders back and forth. 

For each color that you select for the legend boxes, add that color to your swatch by dragging it into the 
Swatches toolbox. Repeat this for all the boxes until you have a unique color for each and a complete color 
swatch. 

13) We now have to change the colors of the barcharts at each node to match the legend. To do this, zoom in on one of 
them, using the zoom command (or push the Z key to zoom with a window). Note that the color bars and black outlines 
in the barcharts are probably separate elements.  

a. Delete all the color fill objects from the barcharts (by selecting inside the bar and pushing Delete). You can 
ensure that you’ve selected the color fill by looking in the ‘Color’ toolbar with each element selected to make 
sure you have the filled object and not the black outline. 

b. Select all the remaining black outlines and change the stroke weight to 0.5pt. You can do this in the ‘Stroke’ 
toolbox. 

c. Select each bar outline in turn and, using the ‘Color’ toolbox and your swatches, assign each color (in order) to 
the bars. You can do this simply by clicking the color in the swatch while the fill color box is active (the ‘Color’ 
toolbox should show a black outline and an empty fill, as a white box with a red line through it). 

Repeat this for all the barcharts (one at each terminal node). 

14) The last thing we’ll do is add a caption to this figure. To do this, we’ll need to add a box of text below at the bottom 
that explains the figure. We’ll start by making some room for this caption. 

a. Click on the artboard tool in the main toolbar. Drag the bottom handle down to add some artboard space 
below your figure. Make this sufficiently large. You can always resize it smaller after you make your caption. 

b. Click on the text tool in the main toolbar. With this tool, you can either just click somewhere to insert short 
text or labels (all one line, no word wrap), or you can drag a rectangle to create paragraph text. 

c. Drag a rectangle at the bottom of your figure. Again, make this more than large enough for your caption. We 
can always resize it later. 

d. In the paragraph text box, write the caption: Figure 1: Multivariate regression tree of Alberta climates, 
showing the proportions of major forest tree species (indicated by colored bars) within in each climate group. 

e. Note that you can change the font, font format, and other type preferences using the ‘Character’ and 
‘Paragraph’ toolboxes. You can also drag the handles on your paragraph text box to resize it to fit nicely. 

f. Once you have it all fitted and looking good, you can resize the bottom of the artboard to just below the 
caption. 

15) You can now save this cleaned MRT graphic. Illustrator will let you save it in a variety of formats:  
AI: Illustrators native file format; vector format that saves all your layers, elements, formatting, etc.  but can only 
be opened in Adobe Illustrator. 
PDF: Adobe’s widespread vector format; will save all your layers, formatting, etc. and can be opened using Acrobat 
and can continue to be edited when opened in Illustrator. This format is great, but be cautious! If you save it again 



in Acrobat or do anything to the PDF, you may lose your layers, etc. If you want to strip the editing information off 
the file, deselect the “Preserve Illustrator editing capabilities” box when you save your PDF. This doesn’t save much 
file size, however, so I’m not sure why you would do this. If you do this, you will also lose any elements that are 
hidden or located outside your artboard. Be careful here. 
Just about any other vector format: You can peruse through the list of file types in the ‘Save a copy’ dialogue box.  
Just about any raster format: You can export your Illustrator file as an image using the ‘File’ -> ‘Export’ command. 
You can change almost any of the compression settings for any format here. 

 
I would suggest that you save your work as an Illustrator file (AI). This will ensure that you always have an AI copy with all 
your formatting and layers that you can modify or change later. It also never hurts to save a PDF, using ‘File’ -> ‘Save a 
copy’, for distribution or straight printing. 
 
For inclusion into a printed document, you may want to save as a EMF or as a high-resolution raster format. Try a few of 
these out to see how they look.   



Illustrator tool guide 
 


